Import of custom sounds

Hi - facing the following issue:
--> trying to import a custom sound into a custom map

In the map is already a custom sound - who works fine since weeks 8or longer).

Yesterday I tried to add an other sound into the map (wav - 16bit - mono - 44khz - 172 kn - 705 kbit/s).

The import itself looks good - SoundNodeWave and SoundCue

The sound will be played back as well in the Content Browser.

The is just one small difference - instead of the information "Mono" you find an "unconverted" (see picture).

If you save the map and close the editor - an reopen the map - SoundNodeWave and SoundCue has been disappeared.

If you check the UMAP file with an editor - you will just find a note for the older wav file - nothing about the new one.

I used a fresh default map and tried once agian - same behavior.

I asked Muzza455 about support - he tested as well with a wav file he used before - but same behavior.

The version of the Editor is --> version 9656 - Changelist 1202061

Will now open a ticket with the AAPG support team for investigation.

If you have the same issues - let me know - if you have a solution - I'm also interested ;-)))) =)

Kind regards


  • (Beer_me)lobo(Beer_me)lobo Posts: 649Player
    i take it you placed the sound cue on the map before saving ?
    Capture.JPG 38.6K
  • Vadder-BearVadder-Bear Posts: 29Player
    Thank you for your feedback.

    No it is just the import - without placing anything already on the map.

    Are you able to reproduce it - so just adding sound (SoundNodeWave and SoundCue) and save - and close it - re-open it and see if it still available in the ContentBrowser.

    Kind regards
  • (Beer_me)lobo(Beer_me)lobo Posts: 649Player
    if you dont put it on the map it wont save , like any external asset that gets imported
  • Vadder-BearVadder-Bear Posts: 29Player
    Ok - will try out and let you know
  • Vadder-BearVadder-Bear Posts: 29Player
    I did some more tests today on a fresh standard map.
    I was able to import the files - and to activate them in kismet.
    Saved the map - closed the editor and re-opened the map.
    Sound was still working.
    The only difference was (I assume), that I didn't closed the editor - so just opened the next map in the editor - and closed the editor later the day.
    Let's take something positive - sound files are OK and I got it working on a test map.

    Will try it now on the "real" map.
  • Vadder-BearVadder-Bear Posts: 29Player
    Doing the same on the "real" map - doesn't work.
    The "real" map is also based on the same default map as the one I tested with.
    So what is the difference????
    Does it just work if the map is nearly empty???
    Any help is more than welcome.
  • Vadder-BearVadder-Bear Posts: 29Player
    I tried to compare the information in the UMAP-file itself (of both maps - working and non working)

    As you can see in the file below, it looks like that parts of the file name has been replaced with "special" characters.

    If you open the map goes via content browser to these sound - the content browser stops working - and the editor as well. Just a kill of the editor will help to get away.
  • Vadder-BearVadder-Bear Posts: 29Player
    Tried to use a very short path without spaces to see if that makes any differences - but still the same.

    Noticed something else - if I save after the import, I'm getting a message saying:
    "Couldn't save packages. Check log windows for further details" --> re-try
    If you save once again - all looks fine
    Picture of Log is below.
Sign In or Register to comment.