UGC custom maps

Hello,

Our server got deleted after last update,
I lost all my settings and had to set it up again. (good thing I had backups of all the config files right?)

well, when it comes down to the UGSmanager, then theres something off.
Ive tried to add all the settings I had previously but it will not allow anyone to vote for any of the UGC maps in the server.

The Custom Maps show up on the vote list. but get this message: "You cant vote for this map"

If I log in as admin to force change it, then the maps are not even on the map list..

***custom maps added on the UGC manager with ID strings as before.
***Added them on the mapvotelist (in default game INI)
***Also added them to rotationlist (to check if it made a difference)
***Then restarted server several times and tried the same setup over and over (just in case it takes some time, as it did before after 3 restarts)

I forgot something for sure, but what?

Comments

  • -=HELL=-Pr0b3-=HELL=-Pr0b3 Posts: 82Player
    Offcourse,
    As Mentioned, as a player voting for mapchange you can see the custom maps. Just cant select em.

    As an admin you cant even see the maps on the list.

    Plus, the server shows as white on the server list. Should show as red, just like your server.

    I must have missed a config line maybe, any config line to activate or deactivate The ugc manager and map downloads?
    If so,I cant find it

  • (Beer_me)lobo(Beer_me)lobo Posts: 626Player
    double check your lines i once deleted a . by accident and had similar issues
  • -=HELL=-Pr0b3-=HELL=-Pr0b3 Posts: 82Player
    yeah I will have a look, thanks!
  • -=HELL=-Pr0b3-=HELL=-Pr0b3 Posts: 82Player
    edited February 2
    Could not find anything, added a "+" infront of the lines tho,
    Still looks like this:
    One picture as Admin, and one a a user on the vote menu
  • -SD-DELTON-ACI--SD-DELTON-ACI- Posts: 1,418Player
    Make sure you have put them in UGCManager like this.

    [SteamUGCManager.SteamUGCManager]
    ServerSubscribedItems=(IdString=669893982)
    ServerSubscribedItems=(IdString=1101310051)
    ServerSubscribedItems=(IdString=931627153)
    ServerSubscribedItems=(IdString=901153539)
    ServerSubscribedItems=(IdString=669893982)
    ServerSubscribedItems=(IdString=548511959)
    ServerSubscribedItems=(IdString=544955983)
    ServerSubscribedItems=(IdString=491197557)
    ServerSubscribedItems=(IdString=894055445)

    [AALauncher.ClientSettings]
    Connection=true
  • -SD-DELTON-ACI--SD-DELTON-ACI- Posts: 1,418Player
    In DefaultGame.ini they should look like this

    +MapRotationList="flo_DoubleImpact$76561198010761141_th"
  • -SD-DELTON-ACI--SD-DELTON-ACI- Posts: 1,418Player
    If you use AAGame.ini they should be put in like this

    MapRotationList=flo_DoubleImpact$76561198010761141_th
  • -=HELL=-Pr0b3-=HELL=-Pr0b3 Posts: 82Player
    It got fixed today,
    Workshopfolder was missin In server file folder, aapg/binary/win32/steamapps

    Libraryfolder.vdf had to be deleted.

    Server restarted.

    We also deleted thetwo lines in bottom of the ugsfilemanager concerning version.
    Updated the ugc manager file again with the maps we wanted and it works again now.

    Thanks to XtremeDelta

    Hopefully this will help anyone with the same issue in the future :)
  • Keebler750Keebler750 Posts: 3,546Beta Tester
    edited February 2
    NICE!!!! You crazy buncha hackists!!! :D
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
Sign In or Register to comment.