Recent fps drops

... from last update or something I get huge fps drops in every map. Before I had over 125 on almost every map (exclude coldfront), now there's konstant drops on 40 or less. Already tried all optimizations, settings but it doesn't matter if I have max graphic settings or Lowest. U can't enyoy game like before.

Runing on: i5 4690k, msi gtx 660
«13

Comments

  • -sVs.rQm^-sVs.rQm^ Posts: 73Player
    set your fps cap to 60 and see what happens
  • ElementisElementis Posts: 134Player
    edited January 2016
    ... from last update or something I get huge fps drops in every map. Before I had over 125 on almost every map (exclude coldfront), now there's konstant drops on 40 or less. Already tried all optimizations, settings but it doesn't matter if I have max graphic settings or Lowest. U can't enyoy game like before.

    Runing on: i5 4690k, msi gtx 660

    Same problem here. I know some guys that are running AMD cards say they are still getting about 150 fps. Is this just a Nvidia card issue? I have a 780 GTX Poseidon. Between rounds, during the scoreboard, my fps shoots up to over 100 fps, then as soon as the round starts, it drops to 40-60 fps.

    I use to get 144-200 fps in beta and the 1st week of the official release (01 Oct 15), Something has changed and not for the better in my opinion.

    And yes, I have a 144 hz g-sync monitor, 32 gb of Trident X memory, crosshair v formula z mb, 8350 cpu, corsair neutron gtx 240 ssd, and running Windows 10 (64-bit).
  • -]Rs^N!33!o.-]Rs^N!33!o. Posts: 2Player
    Same problem here! I've a GTX660ti and stay between 40 and 60 fps.
    Battlefield 4 i can play smoothly with Ultra quality.....Ultra! :,(
  • K!Dz.applePIEK!Dz.applePIE Posts: 1,050Player
    anyone tried the game with the skylake cpus? Since the engine is UE3 and all.
  • CrushmasterCrushmaster Posts: 501Player
    I'm running on a Skylake with no problems.
  • -SelfishGod--SelfishGod- Posts: 4Player
    edited January 2016
    So any stuff/devs comments? Can't find other reason, so it's game lacking optimization. Anyone can comfirm?

    Some players don't care about stable fps, but there's alot of other that want over 100 STABLE fps.
    In competative game it's [TOS Violation] needed!
  • -]Rs^N!33!o.-]Rs^N!33!o. Posts: 2Player
    i've bought a used ati card (R9 290x). This evening i'll test it and I'll let you know if the issue is related to the nvidia card.
  • ={101st}=Muzza455={101st}=Muzza455 Posts: 1,094Player
    You should also consider if you have had a graphics driver update . I wound mine back to original driver for geforce and pull 90 to 130 fps on most maps over WiFi .
  • ={101st}=Muzza455={101st}=Muzza455 Posts: 1,094Player
    Anyone running win 10 there is an issue with new geforce driver .
  • [XIII]Baragon[XIII]Baragon Posts: 21Player
    Ok, I had almost the same scenario, but i'm not sure either one of you are using a laptop or not.

    Check these I list below if it fixes anything to you.

    1. go to your NVidia settings and let it override all applications. sometimes CPU switches over and screws things up

    2. go to your power settings and put it to high performance profile in the battery options.

    3. NVidia drivers seems to work differently to the game. so if you have issues with the newest updated one, go back and check to download a bit older graphics driver from NVidia archives.

    4. I don't recommend this but- if you think your computer is already pushing to the limits of the performance, go and change your .ini settings. in my earlier laptop I managed to get 15 - 20 fps higher of what I had.

    because I believe you need to have at least 50-60 fps to play the game well

    Cheers!

    Baragon
  • -SelfishGod--SelfishGod- Posts: 4Player
    I was always running AA on stable 140-144 fps except coldfront. I already tried everything, but usualy when I play for 15-30 min everything is ok than fps start droping all the way to 40 sometimes on 0 for a second. I can't figure this out its too random. All other games running smootly (more demanding). My graphic settings are all on max perf. settings.
    But I must say something I have done idk what, game runs better than few days ago. Still not smooth as should be.

  • I also have an issue with FPS, currently I can play 1-2 rounds capped at 90 fps then i drop to 30 then i drop off to 12-20 fps also I get some weird sound bugs too where it sounds like there are 1000 guns firing all around me at the same time.... that only happens when im getting the 12-20 fps...
  • Keebler750Keebler750 Posts: 3,607Beta Tester
    There have been multiple threads about the latest Nvidia drivers causing issues. That seems to be the one thing not being addressed here...
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750 wrote: »
    There have been multiple threads about the latest Nvidia drivers causing issues. That seems to be the one thing not being addressed here...

    can you address it please?
  • IO_i_OIIO_i_OI Posts: 1,107Player
    edited January 2016
    The GTX 660 sounds a bit outdated. I use to play with a GTX 750ti and could only manage about 75 FPS. Some maps are more demanding on your GPU. Cold Front is one of them.

    nVidia users should try to roll-back to older drivers to see if that helps.
    googley avatar aapg


  • Keebler750Keebler750 Posts: 3,607Beta Tester
    I don't have time to do the leg work, but some of the recent driver updates at Nvidia have caused problems, and going back to older driver versions has been reported to fix it. There are posts here on the forum about it, as I mentioned.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • i've tried those ideas already.... thought you had something new i've rolled back to a Feb driver still no change
  • -Ner0--Ner0- Posts: 1,574Player
    I have no issues with the latest driver, 120/130 fps with a 660Ti.
    HJbSf8Tt.jpg?2
    Think positive thoughts,
    say positive words,
    do positive actions
    and the positive grows.
  • ElementisElementis Posts: 134Player
    edited January 2016
    -Ner0- wrote: »
    I have no issues with the latest driver, 120/130 fps with a 660Ti.

    Well glad you are not having trouble, but a lot of us are. I tried rolling back drivers too and it didn't make any difference. Last night I joined a server and was getting about 120 fps for the 1st round or two, then it dropped to 40-50 fps. It's strange that between rounds, when the scoreboard pops up, I get over 100 fps, but then when the round starts it drops drastically. Does this possibly have anything to do with AAPG "fixing" their memory leak issue in the last update or two? And if this were nvidia's problem and not AAPG, then why do others state their other games run great without any problems? This issue needs resolved soon, because it is making the game hardly bearable to play.
  • TheTotsTheTots Posts: 2,279Player
    The memory leak fix we most recently put in was for the server so it wouldn't have any impact on your fps. As to why some people have the issue and some don't if you have the same drivers, well, there's also a lot of other hardware and software involved in your computer.

    Computer set ups are extremely different from person to person. Sometimes it can be a program you are running outside of the game causing it, sometimes it can be a conflict with a certain piece of hardware, etc.

    It's hard to pin down, so that's why the more information we get, the better. It's very hard when it's an uncommon issue that we can't reproduce in house, or with any of our beta tester team. Between our studio and the betas we are testing on well over 200 different PC setups, but that doesn't always mean you can see everything unfortunately.
    The game wasn't made exactly to my specifications, so I feel it's broken.

Sign In or Register to comment.