'Connection Lost' - Seems to be targeting certain players ONLY and USA Clan

Hi All,

I wanted to bring this forward and see if there are others in our community experiencing this issue.

Over the past few months, many of the -[U|S|A]- clan members have been having trouble playing the game due to repeated 'Connection Lost' messages when in game. We have played on several other clan servers, as well as official servers, and this issue follows.

It is NOT a punkbuster message... it simply appears as though the player losses connection with the server they were just on. Promptly reconnecting is not an issue, and then either moments or minutes later, the issue reappears.

What have we done to troubleshoot and isolate, well a TON of things, but the following stand out:
- Update Punkbuster using PBSetup.exe as well as re-install the Punkbuster services using their tool
- Ensured TLS version 1.2 is enabled using Internet Options (TLS 1.0 and 1.1 are no longer globally supported)
- Some users have registered new soldiers, as well as new accounts with AA to isolate the issue

Does anyone here have any ideas on what could be causing this issue?

As a community, many of us have lost the ability to play this game, and sadly many have either left our clan to disassociate themselves to USA in order to be able to play, and others have simply moved onto other games.

Thanks for reading.

Comments

  • OICURMT!OICURMT! Posts: 161Beta Tester
    I can try to help, but I'd need a server log file plus a client side log file from the same session in order to try to ascertain what the problem is...
    --

    In life, there is no respawn... why should there be in a game?
  • [soldier][soldier] Posts: 171Player
    edited November 2020
    If you look at the server side logs, all you will see is a normal looking disconnect.

    On the client side you will see what usually happens when you are kicked from a server, but without any of the normal KickBanLog entries preceding it.

    Another pair of eyes on it wouldn't hurt though.
  • -[U|S|A]-Sky-SA--[U|S|A]-Sky-SA- Posts: 6Player
    edited November 2020
    @ OICURMT!

    As [soldier] mentioned above, the logs will not give you much at all then the standard 'lost connection'. I've linked to a screenshot of the only piece of the log that sort of offers some detail.

    Keep in mind, before we start to say, well your server went offline etc etc, this play as well as others are getting this while our server is busy, and are able to 'reconnect' immediately after the lost connection.

    This behavior seems as though something or someone is purposely initiating a disconnect, something maybe like a man in the middle attack.

    As for server side logs, there is nothing other than a disconnect/connection lost message.

    https://media.discordapp.net/attachments/717362114133753957/779852528497852456/8.JPG?width=823&height=389

    https://media.discordapp.net/attachments/778412375417028649/780207079112572938/Screenshot_20201122_180353_com.android.htmlviewer.jpg?width=823&height=380

    https://cdn.discordapp.com/attachments/717362114133753957/782606844153167872/unknown.png

  • OICURMT!OICURMT! Posts: 161Beta Tester
    edited December 2020
    In that case, I might load your tags onto one of my smurf accounts and place a packet sniffer between my comp and the router to see what's going on.

    Before I do that though, I need your permission to display your tags.
    --

    In life, there is no respawn... why should there be in a game?
  • C:\Users\{USER}\AppData\Local\PunkBuster\PG\pb
    or
    Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\pb

    (Can be in other locations sometimes too, depending on windows version. I think Windows 7 was in C:\Users\{USER}\Documents\My Games\America's Army Proving Grounds\Binaries\Win32 from memory.

    Once PBSETUP has run, try the game again,
  • OICURMT! wrote: »
    In that case, I might load your tags onto one of my smurf accounts and place a packet sniffer between my comp and the router to see what's going on.

    Before I do that though, I need your permission to display your tags.

    Permission Granted. You may have troubles loading in as we have tag protection with ACI. But do give it a go.
  • OICURMT!OICURMT! Posts: 161Beta Tester
    edited December 2020
    FYI: I have an account with the playername: -[U|S|A]-NetworkTest

    Played on my local server for about 30 minutes to test things out, no problems.

    Server: Linux 64-bit

    Starting to get a list together of things to try. I've got to setup a Raspberry PI as a sniffer between my client and my router. I'll probably have more time after the holidays as I'm headed to the in-laws for Xmas.

    OIC!
    <LATE EDIT> I'll avoid ACI servers to circumvent the tag protection </LATE EDIT>
    --

    In life, there is no respawn... why should there be in a game?
  • Sounds good. Let me know your findings and if there is anything on this end you want to test.

    OICURMT! wrote: »
    FYI: I have an account with the playername: -[U|S|A]-NetworkTest

    Played on my local server for about 30 minutes to test things out, no problems.

    Server: Linux 64-bit

    Starting to get a list together of things to try. I've got to setup a Raspberry PI as a sniffer between my client and my router. I'll probably have more time after the holidays as I'm headed to the in-laws for Xmas.

    OIC!
    <LATE EDIT> I'll avoid ACI servers to circumvent the tag protection </LATE EDIT>

  • go_ravens8go_ravens8 Posts: 4Player
    it happen's to me all the time when i play and because of that drives me crazy and merry christmas to all
  • I can confirm that I have seen this as well.
    As a player a few weeks ago before I was tagged into a Clan, and since I was tagged as well.
    I have seen it on our Clan server, public servers, other clan servers, and Official Servers.
    I have been subject to it, as well as other Clan members, and friends.

    It nearly always comes alongside a log-out from Steam.

    I strongly suspect it is a momentary de-sync between the authorisation server, steam, the game client, and game server.

    Or, given that most gaming platforms have seen a huge increase in traffic during pandemic, it may just be a data bottle-neck.

    All The Best
  • X|X|XFrankX|X|XX|X|XFrankX|X|X Posts: 7Player
    it attacked the server youre on because it doesn't disconnect from steam or aapg they stay logged in . it disconnects you from the server you join
  • X|X|XFrankX|X|XX|X|XFrankX|X|X Posts: 7Player
    I only make it a min or 2 before it connection lost me I was in usa I left because I wanted to play but im still getting it
  • X|X|XFrankX|X|XX|X|XFrankX|X|X Posts: 7Player
    ok now its on your end I have a new modem with a new ip and new mac # so now its on AA end that cant seam to be as good as they think they are
  • MewtwoMewtwo Posts: 307Player
    hey frank lol or yes you hahaha i think what that is and who did it to.but if i say that namn in here i will get pm and pm and pm over and over again.but like i said i know who that is .

    aka H.E.A.T.
  • X|X|XFrankX|X|XX|X|XFrankX|X|X Posts: 7Player
    ya heres how bad this game is I got a new modem with new mac# new ip # new email addy , new steam , new player name , I played for 3 days it was ok I stayed hooked up now today I connected to server lasted 2 mins got kicked for "connection lost " same bull as before so devs now tell me the truth you let it happen and don't care or you are not looking into it as long as its been going on you could have figured it out
  • Don't know if this issue has been resolved or it is an on going issue. I am still experiencing the "connection lost" and not bein able to play the game. Since I now can't change my profile name is the only way to resolve this is to create a whole new account?
  • Tal256Tal256 Posts: 4Player
    I've just started getting this since the new update. I like this game but surely the devs can quit coding in bugs. It keeps getting worse with age as far as bugs are concerned.
Sign In or Register to comment.