Crashes on startup

I all.

After update I'm not able to start my game up.

Error file:

Log: Log file open, 10/25/20 12:19:29
Log: FEngineLoop::PreInit GHiPriThreadPoolNumThreads=8
Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
Log: ... running in INSTALLED mode
DevConfig: GConfig::Find has loaded file: ..\..\Engine\Config\ConsoleVariables.ini
Init: Version: 9656
Init: Epic Internal: 0
Init: Compiled (32-bit): Oct 9 2020 10:53:56
Init: Changelist: 1202061
Init: Command line:
Init: Base directory: C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\
Init: AAGame Build Info OPEN BETA - CL 319295
2020.10.25-12.19.29 [0000.58] Init: Computer: <hidden>
2020.10.25-12.19.29 [0000.59] Init: User: <hidden>
2020.10.25-12.19.29 [0000.59] Init: CPU Page size=4096, Processors=12
2020.10.25-12.19.29 [0000.59] Init: High frequency timer resolution =10.000000 MHz
2020.10.25-12.19.29 [0000.59] Init: Memory total: Physical=31.8GB (31GB approx) Pagefile=36.6GB Virtual=4.0GB
2020.10.25-12.19.29 [0000.59] Init: Presizing for 33476 objects not considered by GC, pre-allocating 0 bytes.
2020.10.25-12.19.29 [0000.59] Init: Object subsystem initialized
2020.10.25-12.19.29 [0000.63] Log: CachePaths() took 0.04 Seconds
2020.10.25-12.19.33 [0004.15] Log: Found D3D11 adapter 0: NVIDIA GeForce GTX 1070 Ti
2020.10.25-12.19.33 [0004.15] Log: Adapter has 3072MB of dedicated video memory, 0MB of dedicated system memory, and 1023MB of shared system memory
2020.10.25-12.19.33 [0004.23] Log: Found D3D11 adapter 1: Intel(R) UHD Graphics 630
2020.10.25-12.19.33 [0004.23] Log: Adapter has 128MB of dedicated video memory, 0MB of dedicated system memory, and 3967MB of shared system memory
2020.10.25-12.19.33 [0004.24] Log: Found D3D11 adapter 2: Microsoft Basic Render Driver
2020.10.25-12.19.33 [0004.24] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 4095MB of shared system memory
2020.10.25-12.19.33 [0004.33] Log: Shader platform (RHI): PC-D3D-SM3
2020.10.25-12.19.33 [0004.35] Log: PhysX GPU Support: DISABLED
2020.10.25-12.19.41 [0012.14] Log: 97935 objects as part of root set at end of initial load.
2020.10.25-12.19.41 [0012.14] Log: 0 out of 0 bytes used by permanent object pool.
2020.10.25-12.19.41 [0012.14] Log: Initializing Engine...
2020.10.25-12.19.41 [0012.19] Log: Wwise(R) SDK Version 2015.1.4 Build 5497. Copyright (c) 2006-2012 Audiokinetic Inc. / All Rights Reserved.
2020.10.25-12.19.43 [0013.85] TobiiEyeX: FTobiiEyeXController::FTobiiEyeXController()
2020.10.25-12.19.43 [0013.85] TobiiEyeX: FTobiiEyeXController::EyeXInit((null))
2020.10.25-12.19.45 [0016.44] Log: === Critical error: ===
Fatal error!

Address = 0x76669ab2 (filename not found) [in C:\WINDOWS\System32\KERNELBASE.dll]
Address = 0x219c26f (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x2184f0f (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x1f0197f (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]

Comments

  • go_ravens8go_ravens8 Posts: 2Player
    mine is always losing inernet signel but my wifi is good idk why.
  • [!ReDRuM!]L0rdDamian[!ReDRuM!]L0rdDamian Posts: 825Player
    • Tap on the Windows key on your keyboard and type Command prompt.
    • Right click and Run as administrator.
    • Type: regsvr32 KERNELBASE.dll
    • Restart the computer and try to play AAPG again.
  • Daddy-O[OFDC]Daddy-O[OFDC] Posts: 3Player
    edited October 30
    Here is the error when trying that command.


    The module "KERNELBASE.dll" was loaded but the entry-point DllRegisterServer was not found.

    Make sure that "KERNELBASE" is valid DLL or OCX and try again
  • [!ReDRuM!]L0rdDamian[!ReDRuM!]L0rdDamian Posts: 825Player
    edited October 31
    The module "KERNELBASE.dll" was loaded but the entry-point DllRegisterServer was not found.

    Make sure that "KERNELBASE" is valid DLL or OCX and try again

    The error tells me that the DLL is no longer present, this can happen when incorrectly shutting down or have malware on the pc. Let's try adding it again by doing:
    • Tap on the Windows key on your keyboard and type Command prompt.
    • Right click and Run as administrator.
    • Type: regsvr32 /i KernelBase.dll
    • Restart the computer and try to play AAPG again.

    And this question might seem odd, but I had a kernalbase error duo errors with chipsets.
    - What CPU chipset do you currently use.
    - What RAM chipset do you currently use.
    - Which version of Windows do you currently have installed.
  • Daddy-O[OFDC]Daddy-O[OFDC] Posts: 3Player
    Same error.

    CPU Intel Core(TM) i7-8700
    Memory: 16GB (2x8GB) DDR4 2666MHz UDIM M Non-ECC (Total 32 gig)
    Video: NVIDIA(R) GeForce(R) GTX 1070T i with 8GB GDDR5 Graphics Memory
  • [!ReDRuM!]L0rdDamian[!ReDRuM!]L0rdDamian Posts: 825Player
    Oke, well at least you should not have a chipset conflict with intel and your ram. I recommend to check for latest windows update and GPU drivers. After that I would reinstall the game like this;
    • Uninstall the game.
    • Remove everything in: \Documents\My Games\America's Army Proving Grounds
    • Reinstall the game.
    • Update PunkBuster: http://evenbalance.com/pbsetup.php
    • Try to play and see if it still crashes.

    If this doesn't work, I usually just do a fresh install of Windows.
Sign In or Register to comment.