game craches on start

Every time i lunch the game it crashes before starting with no error message, the log text said this
2019.11.22-15.05.16 [0010.36] Log: === Critical error: ===
Fatal error!

Address = 0x1a4c8c8 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0xfa6326 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x2320338 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x1a2f3c8 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x22b66ae (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x22bef92 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x2393dce (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0xfc40ea (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]

and steam wrapper client said this
Fri Nov 22 15:05:06 2019 - Command line ""
Fri Nov 22 15:05:06 2019 - Trying to initialize steam client.
Fri Nov 22 15:05:06 2019 - Steam adjusted GCommandLineConnectionString is ""
Fri Nov 22 15:05:06 2019 - Steam SDK initialized, Wrapper Version 245.101414.1302, loading interfaces
Fri Nov 22 15:05:06 2019 - Steam Apps Init Success!
Fri Nov 22 15:05:06 2019 - Failure setting terminate on heap corruption: 183
Fri Nov 22 15:05:06 2019 - Steam Client Initialization completed.

Comments

  • m_hermannm_hermann Posts: 632Moderator
    we need to see the lines before the crash
  • idk which lines you reference to this is the whole thing
    Log: Log file open, 11/23/19 14:24:27
    Log: FEngineLoop::PreInit GHiPriThreadPoolNumThreads=5
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    Log: ... running in INSTALLED mode
    DevConfig: GConfig::Find has loaded file: ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 9656
    Init: Epic Internal: 0
    Init: Compiled (32-bit): Apr 2 2019 15:02:23
    Init: Changelist: 1202061
    Init: Command line:
    Init: Base directory: C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\
    Init: AAGame Build Info OPEN BETA - CL 272783
    2019.11.23-14.24.27 [0000.32] Init: Computer: DESKTOP-TH3EAQD
    2019.11.23-14.24.27 [0000.32] Init: User: lazfa
    2019.11.23-14.24.27 [0000.32] Init: CPU Page size=4096, Processors=6
    2019.11.23-14.24.27 [0000.32] Init: High frequency timer resolution =10.000000 MHz
    2019.11.23-14.24.27 [0000.32] Init: Memory total: Physical=15.9GB (16GB approx) Pagefile=18.3GB Virtual=4.0GB
    2019.11.23-14.24.27 [0000.32] Init: Presizing for 33476 objects not considered by GC, pre-allocating 0 bytes.
    2019.11.23-14.24.27 [0000.32] Init: Object subsystem initialized
    2019.11.23-14.24.27 [0000.34] Log: CachePaths() took 0.02 Seconds
    2019.11.23-14.24.28 [0001.84] Log: Found D3D11 adapter 0: NVIDIA GeForce GTX 1070
    2019.11.23-14.24.28 [0001.84] Log: Adapter has 3072MB of dedicated video memory, 0MB of dedicated system memory, and 1023MB of shared system memory
    2019.11.23-14.24.28 [0001.85] Log: Found D3D11 adapter 1: Microsoft Basic Render Driver
    2019.11.23-14.24.28 [0001.85] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 4095MB of shared system memory
    2019.11.23-14.24.28 [0001.88] Log: Shader platform (RHI): PC-D3D-SM3
    2019.11.23-14.24.28 [0001.90] Log: PhysX GPU Support: DISABLED
    2019.11.23-14.24.36 [0009.03] Log: 96759 objects as part of root set at end of initial load.
    2019.11.23-14.24.36 [0009.03] Log: 0 out of 0 bytes used by permanent object pool.
    2019.11.23-14.24.36 [0009.03] Log: Initializing Engine...
    2019.11.23-14.24.36 [0009.10] Log: Wwise(R) SDK Version 2015.1.4 Build 5497. Copyright (c) 2006-2012 Audiokinetic Inc. / All Rights Reserved.
    2019.11.23-14.24.37 [0010.11] TobiiEyeX: FTobiiEyeXController::FTobiiEyeXController()
    2019.11.23-14.24.37 [0010.11] TobiiEyeX: FTobiiEyeXController::EyeXInit((null))
    2019.11.23-14.24.37 [0010.15] TobiiEyeX: TX_RESULT_OK = txGetEyeXAvailability(TX_EYEXAVAILABILITY_NOTAVAILABLE)
    2019.11.23-14.24.37 [0010.28] Log: Using AAU Region: 2
    2019.11.23-14.24.39 [0012.67] Log: === Critical error: ===
    Fatal error!

    Address = 0x1a9c8c8 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0xff6326 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x2370338 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x1a7f3c8 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x23066ae (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x230ef92 (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x23e3dce (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x10140ea (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]

  • Also if i lunch it from win64 folder it show this error message
    aapg.PNG 662.2K
  • update
    it work fine now i did no change at all it just get fixed by it self
Sign In or Register to comment.