Error Trying to publish maps

x[BoW]x|NotoriouS^x[BoW]x|NotoriouS^ Posts: 7Player
edited July 14 in Mission Editor - Support
I am getting a "failed profanity check. Update title or description" error when trying to publish maps in the editor to steam.

I know the first question is, is there any profanity in the title or description and the answer is no. So far to troubleshoot this issue i have done the following,

Contacted AA support = Response i got was - "We have never seen this error, post in the forums"
Contacted steam support = Response i got was "We didn't make the game, contact AA" (I knew this was a long shot, but tried anyway)

Next i thought maybe my map file was corrupt in some way. To debunk this theory i sent my .umap file to a friend to try to publish on his PC and he was able to publish it with no issues so i have ruled out the map being the issue and have narrowed it down to my PC being an issue somewhere.

So next i went back to the drawing board to figure this out and thought maybe it could be my PC name was the issue, BAD MOFO. So i changed the name of my PC and my user name account in windows, rebooted and verified in CMD with the command "whoami" and it does reflect my new PC name and new windows user name (administrator). I thought maybe this fixed the issue but, here is the odd part where i think my issue is where i need help.

After i made these changes i went back into the editor to publish, As all of you know who publish maps when you click in the editor to publish, a CMD opens and starts running commands, in those set of commands it list's the file path on your PC where your .umap file is that you are publishing.

Well when trying to publish after my changes, it still is saying the file is in BAD MOFO instead of my new PC name. Could this still be the issue?

I am out of ideas on how to fix this. The only other options i can think of is to have friends publish my maps for me or perhaps create a new steam & AA account on a separate machine to use to publish maps only on.

Comments

  • (Beer_me)lobo(Beer_me)lobo Posts: 645Player
    maybe try setting up a second user account on your pc and do steam/game work on that account
  • x[BoW]x|NotoriouS^x[BoW]x|NotoriouS^ Posts: 7Player
    i tried that as well, same result. its like it has something to do with the file path is not updating. weather its on the AA or steam side is what i can't figure out. And even if i did, neither of them can help.

    Both have made it clear i am on my own trying to figure this out.
  • x[BoW]x|NotoriouS^x[BoW]x|NotoriouS^ Posts: 7Player
    edited July 16
    I wanted to report back in case anyone ever runs into this issue.

    So, if your PC has a name steam does not like, you apparently will never be able to publish maps on that user account in your windows 10. Even if you change your windows 10 user account name (as i did) it will not change or update with steam apparently either.

    I don't know why it didn't work before, but i tried again and created a 2nd windows user account again on my PC and was able to publish to steam. So i am fixed but i have to switch user accounts to do so.

    You have to make sure that user account and PC name are changed to something "steam friendly".

  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Delete the metadata file in your map folder and try publishing. It stores the map info and keeps a connection to the original. If you make the changes you did, that file won't register it. Delete. Republish.

    That's what I'd do. That's also a great way to resolve other weirdness in the publish process.

    I'm not convinced it was a PC naming issue.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • x[BoW]x|NotoriouS^x[BoW]x|NotoriouS^ Posts: 7Player
    edited July 17
    There is no metadata file in the unpublished folder where the saves are stored on the PC.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Oh. So it NEVER published once. Sorry, yeah I get it now.

    Hmm.... :confounded:
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • (Beer_me)lobo(Beer_me)lobo Posts: 645Player
    ive had 1 where i had to fully load the eddy ,before it would publish , don't know why just wouldn't work until loaded the eddy
Sign In or Register to comment.