Server List

Hello,
i need help with setting up my server. When i start it everything goes normaly. I can connect and friends too if i give them my IP. But im not in server list does anyone know why? While server starts it says in the baginning this:
ScriptWarning: No game settings to register with the online service. Game won't be advertised

i hope it helps.
Thanks for any help.

Comments

  • Keebler750Keebler750 Posts: 3,569Beta Tester
    That error message doesn't matter, believe it or not. All servers log that message. :s
    Make sure your ports are all properly open so it'll connect to the proper Steam service. Is it 8765? Something like that.

    Also, there is an issue with the Browser having to be refreshed multiple times to get ANY server to show up. It's a real pain.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    Something like this?
    image.png 42.8K
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    No, that's your server settings for what port to use. Those ports must be opened in your network, in firewalls or routers, etc.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    Say, is there any way you can post your server command line and log after removing any personal details?
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    Okay, here's log from console: https://masmute.net/text/5va7
    Server startup:
    "D:\SteamHDD\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe" server FLO_InnerHospital_EX /STEAMSERVERIP=192.168.0.102 /NOPAUSE /NOHOMEDIR /CONFIGSUBDIR=AAHostAServerConfig-xy -SAP=7780 -SQP=27015
    
    Host Server Screen (just to be sure if it's correct): https://masmute.net/images/scFJ
    Port forwarding from my router: https://masmute.net/images/Wnir
    Firewall Settings: https://masmute.net/images/zusQ

    I'm sure port forwarding and firewall should be correct because friends can connect to me from outside network.
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    I'm suspicious about that /STEAMSERVERIP param. I don;t think it should be there, but I'm going to do some testing before I advise....
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    Okay
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    Try checking the multihome box and the other one. You shouldn't have to fill in ANY IP info in order to run a WAN server. That /STEAMSERVERIP param should NOT be in your command line.

    A LAN server will still be able to be joined by IP from external, so I'd say your ports are fine.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    So which radio button i have to check? Global Internet Server or Lan Server?
    When i remove IP (Bound Server IP and Steam Bound Server IP) it says you must enter your server's ip address. So what address should i type into Bound Server IP and Steam Bound IP local ip? (192.168.0.102) or my public IP? (88.212.xx.xx) Should be Bound Server IP and Steam Bound Server IP same?
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    If you're checking LAN server...that's why the server isn't listed outside your network.

    Check Global, check MULTIHOME. DON'T enter any IPs.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    No I’m not. I’m checking global ofc. Multihome is checked also. If I’m do not enter any IP address it says to me: “You must enter your server’s IP address. It doesn’t let me run server until i don’t fill up any IP address. So any other ideas?
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    Let me go and make a new server to test. You shouldn't have to enter an IP anymore. You ARE using the latest AAGame.exe, right? (Or dedicated?)
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    My Host A Server (HAS) tool autopopulates the "Bound Server IP" text box with the appropriate internal IP of my network card when I start up the UI.

    I don't have to put an IP in.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • OICURMT!OICURMT! Posts: 106Beta Tester
    edited February 10
    Keebler750 wrote: »
    My Host A Server (HAS) tool autopopulates the "Bound Server IP" text box with the appropriate internal IP of my network card when I start up the UI.

    I don't have to put an IP in.

    Unless I'm mistaken, If you are behind a NAT, this address will not be correct.

    You'll need to get your public IP address and then set the routing information on your router/modem to the AAPG ports to direct traffic to your server.
    --

    In life, there is no respawn... why should there be in a game?
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    No, OIC. He's already had WAN connections to his internal network via IP join, so he's already got most of his ports handing off from the router.

    What we're trying to figure out is how to make sure it's a WAN broadcasted server that shows up in the Browser.

    We don't have server Auth anymore, so it's 'supposed' to be much more straightforward. I don't have to add any IP data to the Host a Server tool, and mine works.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • {IM}*Fastkiller{IM}*Fastkiller Posts: 13Player
    Thanks keebler you were right. No IP is needed. I tought i need to fill in my ip cuz it dont letted me copy server command line startup parms. So i had only to press button with no ip and i asked friend to check server list and voila my server is there! Thank you very much for help and your patience! Have a nice day.
  • Keebler750Keebler750 Posts: 3,569Beta Tester
    Excellent!!! Glad it works! Have fun.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • OICURMT!OICURMT! Posts: 106Beta Tester
    Keebler750 wrote: »
    No, OIC. He's already had WAN connections to his internal network via IP join, so he's already got most of his ports handing off from the router.

    What we're trying to figure out is how to make sure it's a WAN broadcasted server that shows up in the Browser.

    We don't have server Auth anymore, so it's 'supposed' to be much more straightforward. I don't have to add any IP data to the Host a Server tool, and mine works.



    Ahhh... Roger!
    --

    In life, there is no respawn... why should there be in a game?
Sign In or Register to comment.