Full Editor Broken.

No matter what I try do anymore in the full editor it just crashes.
Now I can't fully load the content browser. Crashes while loading.

Is there a better way to run the full editor? Or a better editor?
This is my Signature :o

Comments

  • DAMAGER.borgDAMAGER.borg Posts: 16Player


    I can't believe this UDK3 editor is a professional product! or is it AA just F'd it up somehow?

    I want the real UDK3 program then I will just add AA's library assets in it. Is this possible to do?
    This is my Signature :o
  • Keebler750Keebler750 Posts: 3,114Beta Tester
    edited February 18
    My Advanced Editor loads no problem and the Content Browser fully loads all assets. I can open one of my maps.

    Often, when this happens the editor isn't broken. You most likely have a corrupt map that it's trying to load shaders for. I've had this happen to me. Move your maps out of the editor file path temporarily and test by slowly moving them back.

    The other possibility is that you've modified a stock package and it needs to be re-downloaded. Check file integrity.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Dct.F|LeventeDct.F|Levente Posts: 386Beta Tester
    How much RAM do you have? Fully loading everything takes a lot of it, over 8 GB if I remember correctly.
    Theory and reality are not that different. In theory.
  • TheTotsTheTots Posts: 2,279Developer
    That is the "real" program.
    Standard UE3 editor.
    You also shouldn't ever need to fully load the content browser. It's not meant to all be in your memory at once. That's most likely your problem.
    If you have 16 or 32 GB of RAM you may be able to do it and keep good performance. But again, you never really need to load the whole content browser.
    The game wasn't made exactly to my specifications, so I feel it's broken.

  • Keebler750Keebler750 Posts: 3,114Beta Tester
    I note he said he didn't used to have a problem, ergo my advice on corrupt map or package checks. If it had NEVER worked I'd look to memory usage. Wouldn't hurt to make sure unnecessary programs aren't hogging memory though...

    I fully load assets as a matter of course, so I can browse through what's available, but then - I have 32GB of RAM.

    Temporarily move your map folder.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,106Beta Tester
    You most likely saved stock upk file by accident . Look in your Document AAPG folder. Unless you know how to import assets and make your own .UPK files, I'd delete anything UPK in your folder.
  • ={101st}=Muzza455={101st}=Muzza455 Posts: 868Player
    edited February 22
    As wolvy says . If you have altered anything and saved to your map file it will have corrupted 1 of the .upk files. I have done this so many times by miatake . Search pc for all .upk delete all . Then verify game file in steam and re aquire the fresh files . Usually this fixes it.
    If its a map file thats broken and you have it on steam could mean a delete and pull back from your uploaded workshop files.
  • DAMAGER.borgDAMAGER.borg Posts: 16Player
    Thanks all! I did find a few .upk files in my docs save area. Probably from when I tried to copy and modify an AA water asset and a fire particle asset. I think I successfully copy the water and swapped out all of the necessarily files in it and re-saved it. But the particle fire asset didn't want to be copied, it kept crashing the editor program. But the changes I made to the AA particle fire seem to be there when I look at my map in the editor but not in the published map. I guess I will just have to make my own fire from scratch. But thanks guys I will check out your sugestions. If you want you check out my map here: http://steamcommunity.com/sharedfiles/filedetails/?id=1284814299

    This is my Signature :o
Sign In or Register to comment.