Map loading problem

Still having problems with map changing kicking to main menu. Seems like the load time is a great deal too long. I have heard the devs have fixed this problem however I am still having this issue.

Does anyone have a fix for this problem?

Comments

  • Keebler750Keebler750 Posts: 3,252Beta Tester
    edited November 2017
    I've been wondering if the pre-Jan27 maps cause that issue even if you're not switching to them, but they are SOMEWHERE on the server! I'm still seeing this issue too.

    (Or if it's some other issue we never really identified...)
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Two maps of mine are doing this. Maps I created prior to the last update.
  • (Beer_me)lobo(Beer_me)lobo Posts: 609Player
    we find it on beer me servers with umms ,will happen with 1 map 1 day, then next its fine, and an other map will kick to desktop
  • Keebler750Keebler750 Posts: 3,252Beta Tester
    I would venture to say this isn't as 'fixed' as we thought... :(
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • ={101st}=XtremeDelta={101st}=XtremeDelta Posts: 14Player
    I have found the problem, any map that has custom materials must have the shader cache file from personal cach uploaded to the main server. This fixes the pre-loading of maps server side and kicking to main menu.

    Copy C:\Users\username\Documents\My Games\America's Army Proving Grounds\AAGame\Published\CookedPC\LocalShaderCache-PC-D3D-SM3.upk
    To
    \Steam\steamapps\common\America's Army\AAPG\AAGame\CookedPC\

    Any maps that have updates with new "Materials" will need shader cache file re-uploaded.

    "101st Comanchero brigade!"

    ={101st}=XtremeDelta
  • EJtheKEJtheK Posts: 105Player
    Well that's not practical at all. How can we distribute custom maps with custom materials then? It worked in the past, what has changed?
  • Keebler750Keebler750 Posts: 3,252Beta Tester
    I'm trying to figure out how I can write this into a bug report. I can't remember how this used to work properly (because I know it did!) :(
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • The aapg server is originally suppose to save the loaded shaders on the server side after the server is stopped. This works all well and fine with servers ran from a bat file then run command quit the server will save the compiled shaders for the maps loaded on server. The main problem is the way server hosting companies start and stop servers they still use a bat configured file however it seems like they just end the process on restart/stop commands in tcadmin.

    Bat file quit command works while saving shaders
Sign In or Register to comment.