AAGame.exe has stopped working

Windows error message: "A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

It worked 2 days ago but yesterday it wouldn't load.

Here is what I have tried:
1. Verify integrity of game files (on steam). It found 2 and said it updated it.
2. That didn't work so I uninstalled AA:PG completely and reinstalled (downloading the game and UMM content took a full day).
3. That didn't work so I went to \Steam\steamapps\common\America's Army\_CommonRedist\vcredist and ran the 3 different vcredist_x64 files (2008, 2010, 2012).
4. That didn't work so I'm now here.

I thought it could be the Microsoft Visual C++ program causing the issue because I made a minor error.

(I can't remember which day I did this but I think it was prior to the last time I actually played AA:PG.)

I have another game on steam that would always crash so after looking at some options I found a possible solution was to uninstall the Microsoft Visual C++ program. There were 5 listed so I just uninstalled all of them except one which wouldn't uninstall due to certain programs running. I also forgot to make a backup of my PC so I may be in deep trouble here.

I feel stupid for uninstalling programs that I have no idea what they do or what they are for and not having a PC backup file to restore from after I messed up and knew I should have had a backup first.

I can retrieve any log files and list my PC specs if needed.


  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,113Player
    Have you tried removing config files from Documents?

    ...Documents\My Games\America's Army Proving Grounds
    If my trollery drives you crazy, you'd better put on your seatbelt.

  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,113Player
    edited March 2017
    Have you tried removing config files from Documents?

    ...Documents\My Games\America's Army Proving Grounds

    Be careful if you make UMMs they are stored in this file structure, so make a backup of the maps before you remove it, so that you can replace them after.

    Oopps.. Quoted rather than edited, apparently even 2,900 posts on, I'm still a forum newb
    If my trollery drives you crazy, you'd better put on your seatbelt.

  • {IRISH}loxalot{IRISH}loxalot Posts: 64Player
    You weren't specific so I deleted all the files in the Config folder you referenced. I followed that with a verify integrity of game files, waited for it to download what it said was 2 files. Started the game, it crashed.

    Log file:
    Log: Log file open, 03/05/17 11:44:27
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    Log:  ... running in INSTALLED mode
    DevConfig: GConfig::Find has loaded file:  ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 9656
    Init: Epic Internal: 0
    Init: Compiled (32-bit): Jan 26 2017 16:04:27
    Init: Changelist: 1202061
    Init: Command line: 
    Init: Base directory: E:\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\
    Init: AAGame Build Info OPEN BETA - CL 212105
    [0000.34] Init: Computer: DESKTOP-EDFK5BM
    [0000.34] Init: User: loxalot
    [0000.34] Init: CPU Page size=4096, Processors=4
    [0000.34] Init: High frequency timer resolution =3.421873 MHz
    [0000.34] Init: Memory total: Physical=31.9GB (32GB approx) Pagefile=36.7GB Virtual=4.0GB
    [0000.34] Init: Presizing for 33476 objects not considered by GC, pre-allocating 0 bytes.
    [0000.34] Init: Object subsystem initialized
    [0000.36] Log: CachePaths() took 0.02 Seconds
    [0000.76] Log: Found D3D11 adapter 0: NVIDIA GeForce GTX 1080
    [0000.76] Log: Adapter has 3072MB of dedicated video memory, 0MB of dedicated system memory, and 1023MB of shared system memory
    [0000.79] Log: Found D3D11 adapter 1: Microsoft Basic Render Driver
    [0000.79] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 4095MB of shared system memory
    [0000.86] Log: Shader platform (RHI): PC-D3D-SM3
    [0000.93] Log: PhysX GPU Support: DISABLED
    [0009.76] Log: 89351 objects as part of root set at end of initial load.
    [0009.76] Log: 0 out of 0 bytes used by permanent object pool.
    [0009.76] Log: Initializing Engine...
    [0009.93] Log: Wwise(R) SDK Version 2015.1.4 Build 5497. Copyright (c) 2006-2012 Audiokinetic Inc. / All Rights Reserved.
    [0011.82] TobiiEyeX: FTobiiEyeXController::FTobiiEyeXController()
    [0011.82] TobiiEyeX: FTobiiEyeXController::EyeXInit((null))
    [0013.58] Log: === Critical error: ===
    Fatal error!
    Address = 0x7751a832 (filename not found) [in C:\WINDOWS\System32\KERNELBASE.dll]
    Address = 0x200163f  (filename not found) [in E:\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x1fea2cf  (filename not found) [in E:\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
    Address = 0x1d78c0f  (filename not found) [in E:\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]

    I looked and did find the Kernelbase.dll file as well as the AAGame.exe file.

    Windows 10 64bit, 32GB DDR4, GTX1080, i5 6600k
    All drivers and updates are up to date.

    I really don't want to reinstall windows.
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,113Player
    Your not the only person having this exact issue, last I heard, Devs are looking into a possible solution.. in the meantime since the game works for most people, that's enough to tell us it's a problem with your PC somewhere.



    Since you say that you "had" the game working, have you added changed any hardware/software since the game last worked? also, rather than going to the trouble of a full re-install of windows, maybe a system restore to a time the game worked might help?

    Unfortunately it's very hard to remedy issues like this when it only happens to "some" players and not others.
    If my trollery drives you crazy, you'd better put on your seatbelt.

  • {IRISH}loxalot{IRISH}loxalot Posts: 64Player
    I had already read those posts.

    I don't have a backup, thought I did but don't so I'm stuck waiting for devs or doing a windows reinstall.

  • RED@nusRED@nus Posts: 1Player
    I have exactly the same problem, I contacted AA developer K0$H3R and his answer was that they were overwhelmed by the release of AA Proving Grounds on PS4 that this was not important and never heard back from him or anyone of the support staff. I am very disappointed.
  • -=Gorilla=--=Gorilla=- Posts: 501Beta Tester
    If your having this issue then add me to steam and we can go threw a few things that might help fix the problem. Steam is -=MvC=-Gorilla
  • doogle!doogle! Posts: 441Player
    Please share your troubleshooting tips here Gorilla, as it seems there are over 5 threads with this exact issue and no clear resolution. 5 players equates to 29% of the PC versions user base.
  • Keebler750Keebler750 Posts: 3,111Beta Tester
    RidiculousUsername, I'm hard pressed to believe KO$HER said "it's unimportant." My guess is that's your interpretation.

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,111Beta Tester
    By the way, bad UMMs have been known to cause crashes. Could that be it?

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • doogle!doogle! Posts: 441Player
    Keebler I've played a ton of bad UMMs and my game has never crashed B)
  • -=Gorilla=--=Gorilla=- Posts: 501Beta Tester
    I have to agree that some of the UMM can make the game crash on you. I have a vary nice set up and for some reason every once in a blue moon this will still happen. Normally when my PC is trying to do to much because I am running to much. I like to keep myself busy with the 3 monitors lol. As for the tips my plan is to make a video. There are many little things that can cause little issues like this to arise. This would give me another op to do so if I were contacted :P
Sign In or Register to comment.