BSP and decals

Keebler750Keebler750 Posts: 3,605Beta Tester
edited June 2016 in Mission Editor - Support
I'm suddenly having a weird issue in the editor with bullet decals and texture (MIC) decals showing up improperly on BSP surfaces. They're either too dark, totally black, or have a weird background pattern showing inside them. This doesn't respond to typical lighting fixes like a dedicated spotlight on the wall.

If I make a test map, it works fine.

If I go back several map versions, it works fine.

If I delete all lights and put default in, it WON'T work, and if I cut and paste my meshes into a map that the decals DID work.....they stop working.

I already picked Delta's brain on this. What can affect this that I'm missing?

(I haven't published to see if this is Editor only)

I'm afraid to do any more work for fear the map is bugged!
______

This has been a test of the emergency flame-fest system. Please do not adjust your set.

Comments

  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Incidentally, it seems to be the type of decal, whether a bullet effect, or something like a wall damage decal, that has a 'normal map' in it to add a fake 3D lighting effect for depth.

    Other texture-only types of decals like dirt on a wall, or a label, seem to be fine.

    I'm really lost!
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • (Beer_me)lobo(Beer_me)lobo Posts: 642Player
    edited June 2016
    ive seen this with several decals , not sure of the answer ,have you got static lighting enabled on lighting channels for surface properties ?
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    edited June 2016
    Even in the gaze of a DomDirectional...no worky. I've tried all kinds of lighting trickery. Problem is the documentation is slim, or hard to tell what's up to date!

    Shouldn't bullet decals work though? I don't know enough to troubleshoot this!

    I will say this though - I was able to get it to work in a test map, but not in my current build, as i described above. :(
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,187Player
    edited June 2016
    Everytime I've used BSP it leaves horrible looking shadows when lit and never looks as intended. It's why I never use it.
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Update: I found a prior build that properly shows the decals when I build a test block of bsp with the same material and decals as the problem ones in the later build.

    So, when I go to the later build and copy my brushes and try to use them in the PRIOR build, they don't show the decals properly.

    Something's weird. If I can't reset the problem in the later build, I believe I'll have to redo all the bsp....

    :s
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Looks like bad BSP mid-build caused wonky references in the UnrealScript(?) perhaps due to a 'non-coplanar polygons' issue. That's when the problems start as I track up through my builds. I've been looking at the BSP brushes inside a text editor trying to understand what parameters I need to hack, but no success so far.

    If I delete ALL bsp in the map, I can start over and add new brushes that show proper decals, but it seems impossible to do a direct copy/paste of the brushes I want because they bring their 'badness' with them.

    I suspect that the array of brushes within the code gets somehow mixed up.

    Anyway, while I don't like it...I'm going to redo ALL the BSP in my level. Luckily I'm getting quicker at it...!

    I've got stairwells, floors and non-playable buildings that are in bsp.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • ={101st}=Muzza455={101st}=Muzza455 Posts: 1,054Player
    edited June 2016
    Lol m8 sounds fun . I also having probs . All of a sudden one update caused all interpactor shadows to dissappear . Have had to change all and there movement settings and republish. Have not checked on server yet if they are back . Have we had an update in editor to cause these issues ?
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    I'm wondering if we've got a bug.

    In testing last night, this issue IS CAUSED by BSP brushes with non-coplanar polygons (basically your shape got drawn a bit wonky)

    As soon as I had a problem with one of my new brushes, I had a decal lighting issue again on a totally unrelated building.

    The only way I could fix it was to delete all of the brushes that came into contact (intersected) the bad one.

    I still need to see if this issue carries right through the publish process (when I have the time!!!!)
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    I take it back. I'm still having unusual issues. Sigh...
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    No matter WHAT I do, I can not get BSP, textures and decals to work properly in any level I create using the default settings, nor have I found tweaks that will save it. It seems to be any textures/decals with normal maps, including the bullet decals in game.

    It happens even if my BSP is impeccably tidy, and without any geometry issues. So......

    :(

    I'm pretty much ready for the white flag on this one.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,187Player
    Plucking at straws and I don't think I'm entirely sure of the exact problem your having.. but have you tried turning the lightmap resolution up, on the surface material? sometimes that helps with shadows, but I'm not sure about decals.. also, perhaps it's an issue with the material your using on the the BSP some materials will have different properties for things like bullet marks and effects that can affect a hard surface.

    There has to be a way, hospitals walls are primarily BSP.. and decals look fine on them :lol:
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Ya. I've done a lot of different stuff and iterated through some tests. The issue DOES show up in a published build, for instance.

    Meanwhile I have one test map I haven't been able to break. I have no idea why. Time to ignore this issue and move on for now.

    :s
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • [Prt_Dictator][Prt_Dictator] Posts: 275Player
    The red walls in inner are BSP and they have pitch black decals from the guns, even with paintball mode. I would say there is probably some lightning issue all around and not just on your map.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Oh!! That's very interesting. Alright, I've wasted enough time then. On to finish this map1!!

    :+1:
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
  • Keebler750Keebler750 Posts: 3,605Beta Tester
    Gameplay bullet decals, ie when you're shooting, plus a bullet spray decal and a broken wall decal, and there may be more. I can't be sure what the issue is to say it's actually the decal that's the problem, honestly...

    BulletHolesA_JAS_Dcal_INST

    DmgWallD_JAS_Dcal_INST
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
Sign In or Register to comment.