UMM update crashing and looking for guidance

Been hard at working improving the Academia UMM. It plays fine in the editor. Lighting builds okay. It publishes without problems to Steam. But it crashes AAgame.exe upon load. Not sure why or where to look. I have saved only the UMM upk and nothing else. I've imported to that upk some custom textures which appear to work fine. I'm also using some SceneCaptureReflectActors but I've tweaked them to limit their fps impact in the editor. The following is excepted from the error log:

[0368.30] Log: LoadMap: FLO_Academia$76561198066643153_ac?Name=EJtheK?Team=255
[0368.30] Log: --- LOADING MOVIE START ---
[0369.19] ScriptLog: WARNING - Spectator only player leaving spectating state to go to None
[0369.19] DevOnline: Clearing online delegates for AAPlayerController_0 (Player:AALocalPlayer_0)
[0369.19] ScriptLog: Player controller logging out: AAPlayerController_0
[0369.19] ScriptLog: Sending stats and unregistering: EJtheK
[0369.19] ScriptLog: AAPlayerController_0 Cleaning up PRI
[0375.97] Log: === Critical error: ===
Fatal error!

Address = 0x1522027 (filename not found) [in d:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x17af5c7 (filename not found) [in d:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]
Address = 0x14e8f26 (filename not found) [in d:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe]

Groundhog tested it on his game server and had the same crashing issues. Was able to load up the previous working version and republish just fine.

I'd appreciate any wisdom from the mapping gurus on this one. Also any advice on how to test with the game engine locally so as not to burden the community with faulty updates (as I have no other way of knowing if they are bad). Thanks.

Comments

  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    What you mean you saved the " umm upk?" You have additional files besides the . Umap file? So make sure you didn't accidentally save stock upk files. You should have only 1 upk file in your document aapg folder. And that's the local shader upk file. Everything else I'd delete.

    Did you import anything custom? If yes, how and what?

    As far as testing, I'd suggest setting up a home server. That's what I do. I publish my map as private, test it first.... If everything is ok, I change it public so others see it.

    If you still can't find the problem, send me an un-seared version and I'll look at it when I get home.
  • EJtheKEJtheK Posts: 105Player
    Thanks Wolverine. Sorry, I meant "umm umap" file. I, like many others, have learned my lesson a while ago about resaving stock packages.

    I've got some imported meshes and textures. I tried creating a few new material instances and materials. I always select the specific umm file in the browser sidebar, right click and select import.

    Everything seemed to work okay, and there was no indication of problems until after the Steam publish. So what you're saying is to publish to steam, but keep hidden so only I can see it, and run a local server to test, right? No way to avoid Steam while testing? Should I set up the server through "Host Server" or is there a better way?
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    Yes, you'll need a host server. Lan will do it. After publishing the map, you'll need to copy your map file from workshop folder to the stock maps folder. And host your server and log onto it through the browser. If everything works ok, then enable to the public.
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    Also make sure you delete your metadata file from your unpublished folde before republishing. I don't think that has anything to do with it, but sometime that causes issues.
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    I got your PM EJ and have since replied.. sorry it's took so long to respond, this forum does a horrible job of letting one know they got a message :angry:

    Just letting you know incase you tend to miss them as much as I do :lol:
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    You find the problem, Uniy? Or do I need to still look? :#
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    I'm unsure of the problem, he only asked about launching a map offline, so i said to make a copy.. put it in his maps folder and launch it from the console ingame :)

    That's how I always tested mine for setup/functionality in a game environ, since the editor stopped letting you replicate a win to allow you to know if you'd setup the obj's right.

    I'm not sure that would help his crashing issue though.
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • EJtheKEJtheK Posts: 105Player
    Thanks Uni-Sol. That worked and I can now verify my update works before publishing to Steam.

    Still not sure what was wrong with my map. Decided to rebuild the update in smaller steps so it isn't as much lost if something goes south again.
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    edited February 2016
    No problem :) There's also a way you can launch a couple instances of the game on your PC, and have multiplayer too, which can help make setting up and troubleshooting mission hiccups, even better.. it's not so much an issue if you have your own server and lots of people to play with, but for hermits like me this is a god send! infact it's the only way I can make sure everything is working as I'd like it too without publishing a potentially broken map and hope that someone points out whats wrong :lol: Anyways..

    First put a copy of your map in the map folder so the game can find it.. then the fun part..

    Go to your game directory [...Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32") and create a new text document. Rename it to "Server.bat" choose 'all files' in the drop down (not .txt)
    Right click Server.bat, select edit, and type (copy/paste) the following into it:
    C:
    CD "C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32"
    start AAGame.exe server flo_Laboratory.umap?lan
    start AAGame.exe 127.0.0.1?name=Player1?team=0 -log
    start AAGame.exe 127.0.0.1?name=Player2?team=1 -log
    

    In the example above just change the map name from flo_Laboratory.umap to whichever map you want to test (your map name).

    Save it, close, double click on it, you should get a server loading up on your machine with 2 clients.. I for convenience send a shortcut of this .bat file to my desktop, saves from having to keep manually navigating to it :)

    When both games and maps launch you can simply alt-tab between the two to get the game going. It's also worth noting that having two instances of the game running on the same PC can be quite resource intensive, so YMMV depending on your PC's specs.

    I can't all take the credit, any thanks should go to both [Dev]Doc and Altan, both of which are MIA :(


    If my trollery drives you crazy, you'd better put on your seatbelt.






  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    Were the scene capture actors always there, or did you just add them?
  • EJtheKEJtheK Posts: 105Player
    I added the scene actors after... but I even tried removing them and the map still crashed, so I don't think it was them. I'm going to do some more local testing with them now that I know how to see if they were conflicting in any way.
  • EJtheKEJtheK Posts: 105Player
    I tried adding just one scene capture reflect actor to a known working map and tested locally with the game engine. It crashed. So that may have been what buggered everything else up. Too bad, it works great in the editor.
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,163Beta Tester
    I was thinking the same, because I played with that long time ago and it did the same. I suggest removing everything to do with them from your map and do a rebuild. save your map then copy and paste your map into new empty map and rebuild, re-import your other assets and see what happens. If that don't work, let me know and we'll look into further. ;)
Sign In or Register to comment.