2 nades one round :)

Don't know if anyone else has experienced this.
I was rushing upper and I had nade in my hand for blue stairs north. As I threw nade I got flashed. When I get flashed my FPS drops to 0 and my whole game freezes for a second (AMD Flashbang bug). when it unfroze I got a kill with nade I released as I got flashed. Weird thing was I still had another nade in my inventory........ so I selected it and launched it in to north stairs and got another kill. don't think I could reproduce it if I tried. almoast certain it related to the flash bang bug. Anyone else had this????

Comments

  • IO_i_OIIO_i_OI Posts: 1,107Player
    edited November 2015
    I have had nades NOT go off after I threw them while I was being shot. I saw the animation of my throw but no Boom.

    On the other hand, I have been able to cook and throw a nade after I had been shot at close range and get the kill for sweet revenge.

    I have also had animation of throwing a nade but don't see the nade travel and still be able to throw the nade again on the second try.

    I think these are very rare.
    googley avatar aapg


  • ]B4n4nA[JoG@ry]B4n4nA[JoG@ry Posts: 220Player
    what I more commonly get is cooking a nade and launching it only to not have it go off for another 4 seconds like I never cooked it :neutral:
  • JoGary wrote: »
    what I more commonly get is cooking a nade and launching it only to not have it go off for another 4 seconds like I never cooked it :neutral:

    yep
    index.php?soldier=%29ed%28-Willi%40mW%40ll%40ce
  • K!Dz.applePIEK!Dz.applePIE Posts: 1,050Player
    JoGary wrote: »
    what I more commonly get is cooking a nade and launching it only to not have it go off for another 4 seconds like I never cooked it :neutral:

    yep this happened to me also several times. More in the final release than in old beta (could be coincidence though)

    But this double nade is troublesome. Did you by chance recorded this?
  • CrushmasterCrushmaster Posts: 501Player
    JoGary wrote: »
    what I more commonly get is cooking a nade and launching it only to not have it go off for another 4 seconds like I never cooked it :neutral:

    yep this happened to me also several times. More in the final release than in old beta (could be coincidence though)

    But this double nade is troublesome. Did you by chance recorded this?
    I don't think I ever had this in beta, but I have noticed something being off in the full release.
  • AntisleepAntisleep Posts: 7Player
    JoGary wrote: »
    Don't know if anyone else has experienced this.
    When I get flashed my FPS drops to 0 and my whole game freezes for a second (AMD Flashbang bug).

    Do you have an R9 280x or 7970 gpu and running on Windows 10?

    I guess that bug never got fixed.
    Be the tip of the spear.
    wHbqgca.jpg
  • TheTotsTheTots Posts: 2,279Player
    Antisleep wrote: »
    Do you have an R9 280x or 7970 gpu and running on Windows 10?

    I guess that bug never got fixed.

    There's only so much we can do when it's their drivers unfortunately.
    The game wasn't made exactly to my specifications, so I feel it's broken.

Sign In or Register to comment.