Any help would be great

So i luanched my map a few days ago the prague responce and all went well , i made some slight changes the map and built it and saved it and played it and all the cahnges went well , i closed the editor to upload to workshop later tonight as not to stress any servers and i when i try to open the map the editor crashes , i can open other maps fine and the log tells me this .

[0144.45] Log: Encountered missing default brush - spawning new one
[0145.08] Critical: appError called: Failed to find object 'World FLO_ThePragueResponse.TheWorld'
[0145.08] Critical: Windows GetLastError: The operation completed successfully. (0)
[0156.71] Log: === Critical error: ===
Failed to find object 'World FLO_ThePragueResponse.TheWorld'

i really dont want to lose this map i worked so hard on it and for my first map it got a nice responce
any help would be great . Thank you

Comments

  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    edited November 2015
    To rule out some sort of package error, since I know you've used custom assets, remove the .upk rain package and any others you may have used to import assets to your map.. from the location you have it saved to, just to test if the map loads after its removed.

    you may get errors if it does load along the lines of "cant find blabla" or "reference errors".

    Be sure to keep the package, dont delete it, just drag it out of the location its at now to somewhere else for testing.. If it does load, put the package back to where it was and see if it then crashes.

    Depending on whether or not this helps will kinda dictate what else I could suggest, since you can load other maps fine, I doubt its anything to do with stock packages. I'm not sure how else a mapfile can become unloadable.
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • -Flops--Flops- Posts: 354Player
    ok well i tried all that Uni and still no luck , the best i have been able to find is its a texture bug which UE released a hotfix for back in 2013 or something , but the aapg editor still runs the old version so basically the map is borked , all that hard work down the drain lol . on the bright side i still have my other map
  • (Beer_me)lobo(Beer_me)lobo Posts: 649Player
    "FLO_ThePragueResponse.TheWorld'"

    check your map name , would have thought it should be flo_etc,etc .umap
  • -Flops--Flops- Posts: 354Player
    the actually map name in the file path iS FLO_ThePragueResponse.ump , in the log it says .world im not sure why , but according to the forums EU3 its more about the brush error and thats a texture glitch , even with default textures it can happen , i havent imported any textures , like i said i just saved and closed as always and the next time i started it , it just wouldnt work and the only thing i did before last save was move one piece of scafolding , removed the ford escort and made it a touch lighter , saved all ,rebuilt all , and ran it fine . so i am at a lose
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    edited November 2015
    Ahh, sorry to hear :(

    Couple more things to try I guess..

    Delete your config folder from here..

    Documents\My Games\America's Army Proving Grounds\AAGame\Config

    relaunch the editor and map with crossed fingers :) if not..

    If your willing to try something BIG (and time consuming depending on how fast your internet is) please try re-installing the game iself. I've had maps not able to be opened in the past and could never find the issue, re-installing the game was the only fix I ever found.

    Not saying its going to work 100% but sometimes you have to go to the extreme and try everything including starting fresh, don't worry.. you won't lose your map as its stored in my documents not in the games location.. but save a copy of it somewhere to be on the safe side :)

    If none of that works, then i'd assume something must be corrupted inside the mapfile and I'm not sure how to fix anything like that, or even if it's possible :(
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • -Flops--Flops- Posts: 354Player
    i deleted every trace of everything and reinstalled it all again like i did last time , but still wont work , so i downloaded a copy of udk3 and tried to open it that way same error same crash spot , so im guessing thats it for the prague response lol . move forward learn from it , ill be back with bigger better things lol . Thanks everyone again for your help
  • StackEmUp!StackEmUp! Posts: 145Player
    Try looking for a folder named "Assets", or "Packages", in this directory, if you find any, and they are not something that you have made delete those folders:
    "C:\Users\yourname\Documents\My Games\America's Army Proving Grounds\AAGame\Unpublished"

    Look in all the sub folders too. in the past I've had similar problems like this one, it usually happens after I open and look at a material made by the Dev's e.t.c., and even though nothing was changed, it would save a duplicate somewhere in the "Unpublished" directory, and instantly crash that particular map, when trying to reload it.
  • -Flops--Flops- Posts: 354Player
    edited November 2015
    i completely removed it all and reinstalled just basic stuff , still gives me same error . Anyway i appreciate all the efforts everyone taken to help but this one is dead now , i got the rain working for a day lol
Sign In or Register to comment.