Can't join my server

StylEr57StylEr57 Posts: 8Player
edited October 2015 in Server Support
Hello guys,

My server has been activated and associated with my Server's IP. I started the server, rules for port forwarding are created and the server is available in the Serverlist in the Game.

But I can't join it, I tried to connect on it, without result, nothing happens.

If someone can help me? Thank you.
Sat Oct 10 15:12:28 2015 - Log file NOW set to server IP specific log file name of "SteamWrapperServer.xxx.xx.xxx.xxx.7778.log"
Sat Oct 10 15:12:28 2015 - AA3 Steam SDK Wrapper version 245.101414.1302
Sat Oct 10 15:12:28 2015 - Trying to initialize Steam Game Server Init
Sat Oct 10 15:12:28 2015 - MAS found command line options of ""C:\Program Files (x86)\Steam\steamapps\common\America's Army\AAPG\Binaries\Win32\AAGame.exe" server BDX_Breach_EX /GLOBAL  /AuthServerUserName=xxxxxxxx /AuthServerPassword=xxxxxxxx /AuthServerIP=xxx.xx.xxx.xxx  /STEAMSERVERIP=xxx.xx.xxx.xxx  MULTIHOME=xxx.xx.xxx.xxx /NOPAUSE /NOHOMEDIR /CONFIGSUBDIR=AAHostAServerConfig0 /DISABLEUMM /SAP=7783 /SGSP=7778 /SQP=27015 /INST=1"
Sat Oct 10 15:12:28 2015 - MAS Auth options path is "MASAuthOptions_AAHostAServerConfig0.ini"
Sat Oct 10 15:12:28 2015 - Found "MASAuthOptions_AAHostAServerConfig0.ini" options.
Sat Oct 10 15:12:28 2015 - Opened "MASAuthOptions_AAHostAServerConfig0.ini" options.
Sat Oct 10 15:12:29 2015 - Steam Game Server Manager initialized
Sat Oct 10 15:12:29 2015 - WARNING: Wrapper Server Settings not found
Sat Oct 10 15:12:29 2015 - Starting Steam Server for IP "xxx.xx.xxx.xxx" on port 7778 with game version "4.0.1" (Mode: INTERNET)
Sat Oct 10 15:12:29 2015 - Trying to initialize Internet steam server with IP of "xxx.xx.xxx.xxx", Game Server Port 7778, Updater Port 27020
Sat Oct 10 15:12:29 2015 - Authentication port: 7779, Server Directory (Steam browser identifier value): "aa4game"
Sat Oct 10 15:12:29 2015 - Game Server Version: 4.0.1 (although we are forcing use of "1.0.0.0" as required by back end).
Sat Oct 10 15:12:29 2015 - Initializing server with VAC disabled.
Sat Oct 10 15:12:29 2015 - Contacting Steam Server Init Service.  APort: 7783, GSPort: 7778, QPort: 27015
Sat Oct 10 15:12:29 2015 - Steam Server Init Service successfully initialized
Sat Oct 10 15:12:29 2015 - Inserting shared server data entry at index 0 for server "xxx.xx.xxx.xxx7778"
Sat Oct 10 15:12:29 2015 - Server process ID is 171c
Sat Oct 10 15:12:29 2015 - Steam Game Server Initialized
Sat Oct 10 15:12:29 2015 - SteamServerMonitorThread running.
Sat Oct 10 15:12:29 2015 - UMM Command line is ""C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\AMERICA'S ARMY\AAPG\BINARIES\WIN32\AAGAME.EXE" SERVER BDX_BREACH_EX /GLOBAL  /AUTHSERVERUSERNAME=xxxxxxxxx /AUTHSERVERPASSWORD=xxxxxxxx/AUTHSERVERIP=xxx.xx.xxx.xxx  /STEAMSERVERIP=xxx.xx.xxx.xxx  MULTIHOME=xxx.xx.xxx.xxx /NOPAUSE /NOHOMEDIR /CONFIGSUBDIR=AAHOSTASERVERCONFIG0 /DISABLEUMM /SAP=7783 /SGSP=7778 /SQP=27015 /INST=1"
Sat Oct 10 15:12:29 2015 - UMM using query port of 7779 (one more than game server port)
Sat Oct 10 15:12:29 2015 - DISABLEUMM found
Sat Oct 10 15:12:29 2015 - UMM Remote instance is 1
Sat Oct 10 15:12:29 2015 - UMM server settings - looking for "..\AAPGWorkshopManager.xxx.xx.xxx.xxx.1.ini"
Sat Oct 10 15:12:29 2015 - UMM  Server Settings found in "..\AAPGWorkshopManager.xxx.xx.xxx.xxx.1.ini"
Sat Oct 10 15:12:29 2015 - INI settings UMM Folder Monitor Scan Frequency to every 600 seconds
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing is disabled by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing command port is 3128520 by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing IP Filtering is disabled by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing IP Filter set to  by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing User Name set to "" by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing User Password set by INI
Sat Oct 10 15:12:29 2015 - UMM Remote Subscribing max storage space set to 0 bytes by INI
Sat Oct 10 15:12:29 2015 - UMM steam monitoring is disabled by INI
Sat Oct 10 15:12:29 2015 - Server found multihome IP of "xxx.xx.xxx.xxx"
Sat Oct 10 15:12:29 2015 - User Made Maps Manager Active
Sat Oct 10 15:12:29 2015 - Steam server management initialized
Sat Oct 10 15:12:29 2015 - Map Info Server IP of "xxx.xx.xxx.xxx"
Sat Oct 10 15:12:29 2015 - Auth Server IP is xxx.xx.xxx.xxx
Sat Oct 10 15:12:29 2015 - UMM querying disabled by command line
Sat Oct 10 15:12:29 2015 - AuthServerUserName is xxxxxxxxx
Sat Oct 10 15:12:29 2015 - Map Info Server IP of "xxx.xx.xxx.xxx" port 3128520
Sat Oct 10 15:12:29 2015 - AuthServerPassword is xxxxxxxx
Sat Oct 10 15:12:44 2015 - MASS status is available, mode reported is 396

Comments

  • StylEr57StylEr57 Posts: 8Player
    edited October 2015
    Hi guys,

    I've checked log files and I found this error in SteamWrapperServer.log:
    Sun Oct 11 18:52:18 2015 - Steam Logging level set to 1
    Sun Oct 11 18:52:18 2015 - Trying to initialize game server access to Steam Master Server.
    Sun Oct 11 18:52:18 2015 - Failure setting terminate on heap corruption: 2
    

    How can I solve this?
    Thank you.
  • m_hermannm_hermann Posts: 656Moderator
    kind of tough without the IP to look at it
  • StylEr57StylEr57 Posts: 8Player
    Hello m_hermann,

    The IP is 151.80.118.165

    Thank you.
  • m_hermannm_hermann Posts: 656Moderator
    server seems to be offline at the moment
  • StylEr57StylEr57 Posts: 8Player
    edited October 2015
    m_hermann wrote: »
    server seems to be offline at the moment

    I started it again!

    I've got the message "connection lost" 5mn after clicking on my server to join it.
  • m_hermannm_hermann Posts: 656Moderator
    still nothing
    https://www.gametracker.com/search/aapg/US/?query=151.80.118.165

    [0110.37] ScriptLog: [SERVER BROWSER] connecting to inputted IP address: 151.80.118.165:7778
  • StylEr57StylEr57 Posts: 8Player
    I don't undersrand, Server is started and is available in the server list?!?!
  • -=DA=-Tw!$t3d-=DA=-Tw!$t3d Posts: 65Player
    If your hosting this on your own machine.
    1. Open the windows firewall with advanced security
    2. Right click on Inbound Rules
    3. Select New Rule
    4. Select Program, Click Next
    5. Browse to where your AAGame.exe is located, Click Ok, Click Next
    6. Select Allow the connection, Click Next
    7. Make Sure Public is checked, Domain and Private may also be checked, but not needed.
    8. Name it, Click finish.

    This works way better than just opening certain ports. It will allow all requests that that program is listening on to be accepted. Functional, and Secure.
  • m_hermannm_hermann Posts: 656Moderator
    I can't get the server to respond to my join request and I can't see it in a third party browser. Please validate the network connections and firewall access as suggested.
  • StylEr57StylEr57 Posts: 8Player
    edited October 2015
    If your hosting this on your own machine.
    1. Open the windows firewall with advanced security
    2. Right click on Inbound Rules
    3. Select New Rule
    4. Select Program, Click Next
    5. Browse to where your AAGame.exe is located, Click Ok, Click Next
    6. Select Allow the connection, Click Next
    7. Make Sure Public is checked, Domain and Private may also be checked, but not needed.
    8. Name it, Click finish.

    This works way better than just opening certain ports. It will allow all requests that that program is listening on to be accepted. Functional, and Secure.

    Hi,

    the Server is hosted on another computer (VPS).

    Inbound Rules are already done:

    16iiqzr.png

  • StylEr57StylEr57 Posts: 8Player
    edited October 2015
    m_hermann wrote: »
    I can't get the server to respond to my join request and I can't see it in a third party browser. Please validate the network connections and firewall access as suggested.

    Hi,

    I can see my server in the Server List in game ("Styler's America's Army Server").


  • StylEr57StylEr57 Posts: 8Player
    edited October 2015
    Well it's working now:

    In the Inbound Rules I had to allow AAgame.exe and not only AALauncher32.exe !

    Thank you all and Thank you -=DA=-Tw!$t3d !
  • m_hermannm_hermann Posts: 656Moderator
    Thanks for responding with the solution, we see this same issue from time to time
  • -=DA=-Tw!$t3d-=DA=-Tw!$t3d Posts: 65Player
    StylEr57 wrote: »
    Well it's working now:

    In the Inbound Rules I had to allow AAgame.exe and not only AALauncher32.exe !

    Thank you all and Thank you -=DA=-Tw!$t3d !

    You're very welcome, sir.
Sign In or Register to comment.