.

-SD-DELTON-ACI--SD-DELTON-ACI- Posts: 1,511Player
edited December 2016 in Server Support
.
gKQ6BB2.png

Comments

  • DeltaKiloDeltaKilo Posts: 146Developer
    We currently have an issue with publishing maps from the editor to the workshop, we are working on a fix. You can't run the old maps on your server without opening them in the new editor and re-publishing them.
  • -SD-DELTON-ACI--SD-DELTON-ACI- Posts: 1,511Player
    Ok thanks.
    I have all my maps ready to publish :)
    gKQ6BB2.png
  • [hwy]stitch[hwy]stitch Posts: 11Player
    so can I open another persons old map and republish to get it to work?
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,165Beta Tester
    As long as it wasn't cooked. I would suggest asking for permission however. ;)
  • [hwy]stitch[hwy]stitch Posts: 11Player
    nvm for some reason I cant download the editor from steam.
  • -Ner0--Ner0- Posts: 1,576Player
    edited October 2015
    nvm for some reason I cant download the editor from steam.

    I had the same issue, but suddenly it was there after they updated the game.
    http://forum.americasarmy.com/discussion/comment/17142/#Comment_17142
    HJbSf8Tt.jpg?2
    Think positive thoughts,
    say positive words,
    do positive actions
    and the positive grows.
  • DeltaKiloDeltaKilo Posts: 146Developer
    We found the issue that was causing the crash when publishing. Testing it and should have a patch out within a few days to fix it.
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,165Beta Tester
    Great news! appreciate it as always! :+1:
  • (Beer_Me)Roach(Beer_Me)Roach Posts: 249Player
    That is great news Delta , Thanks for the speedy attention guys. We do appreciate it.
  • So, where are we on this? Is it ready? Are we still waiting?

    Thanks,
    -Rabbit
  • -=}WoLvErInE{=--=}WoLvErInE{=- Posts: 1,165Beta Tester
    Hey Rabbit,

    It's still being work on. I'm sure once it's ready you'll see some kind of announcement/ post from the Dev's.

    Many us are waiting for this. ;)
  • Alrighty, UMMs are now supported. but for the life of me, I can not figure out how to upgrade the older maps. Using the full editor, if I rebuild the map, it either crashes during upload, or if it does upload comes up with a version mismatch when trying to load in. So what is the trick? What exactly needs to be changed on the older maps to make them compatible?

    Thanks.
    -Rabbit
  • [CLS]_SgtMac[CLS]_SgtMac Posts: 199Moderator
    Have you followed all the steps listed under "Whats Changed: For Map Creators" here:

    Official Guide to What's Changed with UMMs in v1.0
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    I sadly had the same issue, I went to the resort of deleting all my old maps from their physical location and removing the maps that did not work from the new steam workshop location, made sure to un-sub from them in steam and then started fresh :(

    It was painful thing to do as I don't have backups since I not long ago rebuilt my PC. Funny thing is the first time I tried to uplaod my map, once ingame it loaded one of my other maps, it was very weird.

    I now only have the 1 map, where I used to have 4-5 :(
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • [CLS]_SgtMac[CLS]_SgtMac Posts: 199Moderator
    Have you tried creating the metadata file mentioned in the quide?
    Metadata Files
    When you publish your map, a ".metadata" is created alongside it, and automatically uploaded with it. This file makes map management easier on servers and clients. You shouldn't have to modify this file under normal circumstances.

    For pre-1.0 maps, if you've renamed an Item in the Workshop and the saved .umap name doesn't match, you may need to create a .metadata file in the folder with your map. Create the file, open it in a text editor, and add the following:
    PublishFileId=<Your Item Id>

    (You can find your Item Id by looking at the URL of your Item in the Steam Workshop: http://steamcommunity.com/sharedfiles/filedetails/?id= <This is your Item Id>)
Sign In or Register to comment.