Landscape Editor Issue

Hey guys! This one is crazy! So I was working on my map all day, editing the landscape to look pretty. Everything is working as expected. Suddenly I went to paint a small section, and it turned almost half of the map a grey color.

q9rqgj4.jpg

When I try to paint over the grey, it ignores my brush size and paints the whole component.
In these two screenshots, I only clicked the button once at each location, you can see how its painting whole components.

qV9o4NB.jpg
HChp93g.jpg

Then, I tried using a different target layer, grass, and it turns most of the component grey again, except a small square where I have the mouse, and its partially covered by the previous one.

ws0brAF.jpg


This is driving me crazy, not sure what to do. I'm assuming I did something to mess it up I just don't know what.
PLevlex.jpg

Comments

  • Oh one more thing to note, if play in editor, the ground indeed looks grey like that, but the sound changes to whatever the correct surface is. I've tried rebuilding all, still no idea what is wrong.
    PLevlex.jpg
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    edited August 2015
    I've had something like this happen when I accidentally moved my landscape when clicking on a grass mesh.. only difference between mine and yours was some parts of my landscape would become invisible when looking at it in certain directions.. as well as grey squares.. it was crazy.

    I ran out of things to try.. Didn’t want to save the map incase it borked it all up so I just ended up exiting the editor and fired back up a previous save and it was back to normal.. Lost a lot of progress that day, ever since then I have had my Landscape locked so it can't be accidentally edited in anyway :lol:

    Sorry I can't be of more help :(
    If my trollery drives you crazy, you'd better put on your seatbelt.






  • how to lock the landscape? That will help in the future!

    I have an old save I can use, its like 2 days ago, I can copy paste the new stuff onto it, but I will still have the same problem. I tried making a new map, same problem. Even in the basic editor the same thing happens. I don't know if my editor is broken or I have a setting changed. Its really strange.
    PLevlex.jpg
  • [ENG]Uni-Sol[ENG]Uni-Sol Posts: 3,193Player
    This is what I do to stop myself from being an idiot.. Select your landscape hit F4 and..

    oqw107.jpg

    There are more than likely easier ways or even correct ways.. but it works for me :lol:

    If my trollery drives you crazy, you'd better put on your seatbelt.






  • Learn something new everyday
    PLevlex.jpg
  • GoodvibeGoodvibe Posts: 94Player
    It might be a bit more work, but incremental saves are really the key to prevent this.
    I had a quick google and this might be it:
    Another issue to watch out for when painting layers is to avoid having too many textures on one component. The material editor stats show the limit of how many texture samples you are allowed to use, but for Landscape materials the masks for each layer count as texture samples too and do not show in the stats. If a component starts showing the default texture (Grey Squares) when you paint a new layer onto it, it is likely that it is gone over the texture sample limit and either needs to have a layer erased or the material needs to be optimized to use less textures.
  • @Goodvibe I saw that when I was googling before asking here, didn't solve my problem either.

    Well I have it fixed now. What I ended up having to do was to paint everything one texture, then go through and paint over it with what I actually wanted. For some components, the grey texture remained and could not be edited, I simply deleted those components and added new ones in their place. All seems to be working now.
    PLevlex.jpg
  • Keebler750Keebler750 Posts: 3,607Beta Tester
    Yep. I was just going to type about painting multiple layers. It seems the editor takes a few passes before that grey goes away. I always saw that when adding new landscape components.

    Glad you got it.
    ______

    This has been a test of the emergency flame-fest system. Please do not adjust your set.
Sign In or Register to comment.