Some key binds do not work in editor

OK, so this is not the first time this has happened, and it usually resolved itself somehow, but this time I can't fix it.

Since coming back from the Opt-in, some of the main key binds no longer work in the advanced editor.

Things like Ctrl-C, Ctrl-V still work to copy and paste, but the space bar refuses to switch between the mode widgets, and delete refuses to remove and highlighted content.
I know there are toolbar buttons for this, but it is easier to use the keyboard.

Can someone please help me get these functions back?
I have checked the DefaultKeyBinds.ini, but this seems to only have some binds which are standard for whatever UDK editor you use (including spacebar and delete for matinee editing only).

As an aside, in the Mission Editor, spacebar works, but delete does not.


  • =[101st]=Wolverine=[101st]=Wolverine Posts: 1,169Beta Tester
    In document folder....Delete all the ini's in the config folder that have to do with the editor. better yet, I suggest just delete the config folder altogether and let the engine create new ones. That should solve your problem.
  • [NoL]W_a_t_c_h[NoL]W_a_t_c_h Posts: 133Player
    Thank you. That worked.

    Before I did it, I actually had another look in the AAInput.ini and the binds were there, but I guess something was bugged and wasn't reading the file correctly. Maybe one of the many editor crashes I have had, just broke it :p
  • =[101st]=Wolverine=[101st]=Wolverine Posts: 1,169Beta Tester
    Great news. ;)
  • [NoL]W_a_t_c_h[NoL]W_a_t_c_h Posts: 133Player
    I think I know what does it. After doing some more editing, I went to play the game and obviously deleting the files had removed all my graphics settings and in-game keybinds.
    I changed most of the settings in the browser interface, and then finished off the last couple once connected to a server.
    Once I finished with that, I went back to the editor and guess what, space and delete no longer function.

    So I checked out the AAInput.ini file, and compared the current one to the one created automatically on removal.

    Current One
    Bindings=(Name="SpaceBar)",Command="MODE WIDGETMODECYCLE",Control=False,Shift=True,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)
    Bindings=(Name="Tilde)",Command="MODE WIDGETCOORDSYSTEMCYCLE",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)
    Bindings=(Name="F2)",Command="SELECT BUILDERBRUSH",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)
    Bindings=(Name="F4)",Command="EDCALLBACK SELECTEDPROPS",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)
    Bindings=(Name="F5)",Command="EDCALLBACK SURFPROPS",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)
    Bindings=(Name="F6)",Command="EDCALLBACK LEVELPROPS",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False)

    Auotmatic One
    Bindings=(Command="MODE WIDGETMODECYCLE",Name=SpaceBar)
    Bindings=(Command="MODE WIDGETCOORDSYSTEMCYCLE",Name=Tilde)
    Bindings=(Command="SELECT BUILDERBRUSH",Name=F2)
    Bindings=(Command="EDCALLBACK SELECTEDPROPS",Name=F4)
    Bindings=(Command="EDCALLBACK SURFPROPS",Name=F5)
    Bindings=(Command="EDCALLBACK LEVELPROPS",Name=F6)

    As you can see, the process on editing the keybinds in the browser reformats the binds to a way that doesn;t work.
    I have now gone into the game and changed my in-game settings and binds, and the resulting AAInput.ini is still the correct format. :D

    Don't know if this is something the devs know about or even care about seeing as they will be removing the browser soon.
Sign In or Register to comment.