Failed to register game with online service. Registering as a LAN match

AnsuexAnsuex Posts: 10Player
For some reason i can't get the server to run.

Here is the full log:

[0005.01] Log: Executing Class Engine.ServerCommandlet
[0005.01] Log: Initializing Game Engine...
[0005.07] Log: LoadMap: BDX_Breach_EX?Name=Player?Team=255
[0005.19] Log: Game class is 'AAGameVeteran'
[0005.19] Log: NetMode is now 1
[0005.21] Log: Primary PhysX scene will be in software.
[0005.21] Log: Creating Primary PhysX Scene.
[0005.21] Log: Bringing World BDX_Breach_EX.TheWorld up for play (30) at 2015.08.20-18.07.18
[0005.21] ScriptLog: AccessControl: Trying to register authentication delegates with an online subsystem that does not support authentication
[0005.21] ScriptLog: (AAGameVeteran_0) AAGameInfo::AAGameVeteran:RegisterServer AAGameSettingsCommon OnlineSubsystemAAPC_0 OnlineGameInterfaceImpl_0
[0005.21] ScriptWarning: Failed to register game with online service. Registering as a LAN match
AAGameVeteran BDX_Breach_EX.TheWorld:PersistentLevel.AAGameVeteran_0
Function Engine.GameInfo:OnServerCreateComplete:010A
[0005.21] Error: Can't create a new online session when one is in progress: Transient.AAGameSettingsCommon_0
[0005.21] ScriptWarning: Failed to register game with online service. Game won't be advertised
AAGameVeteran BDX_Breach_EX.TheWorld:PersistentLevel.AAGameVeteran_0
Function Engine.GameInfo:OnServerCreateComplete:0212
[0005.21] Log: Updated Destroyable List: 0
[0005.21] ScriptLog: Server Steam authentication or LAN MBS initialization starting.
[0005.21] Log: INFORMATION: Trying to load blocked player list from "..\..\AAGame\Config\AAHostAServerConfig0\BPList.dat"
[0005.21] Log: INFORMATION: Trying to load player admin list from "..\..\AAGame\Config\AAHostAServerConfig0\PAList.dat"
[0005.22] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server. Trying again in 15.0000 seconds.
[0005.22] Log: DEBUG AUTH: Game server has steam game id of "90096878187867144"
[0005.22] Log: UTeamSpeakServer::InitializeServer(szName=AAGame Teamspeak Server, szPassword=, szWelcomeMsg=)
[0005.24] Log: UTeamSpeakServer::InitializeServer - ServerLib initialized
[0005.24] Log: UTeamSpeakServer::InitializeServer - Sending ServerIP=192.168.1.24
[0005.24] Log: UTeamSpeakServer::InitializeServer - calling createVirtualServer with port 8765 serverip 192.168.1.24 name AAGame Teamspeak Server keypair MG0DAgeAAgEgAiBnXoZmzmI9LUz4Y4kFW0cFeW3SfrxL7DWooLPXMZw3KQIgNKMuciFJxuN5wyQjVianvcXJMR+lCf1qNstHoext4nICIDZz4oXK7mgBlZcFkn1EWKHT8rL120GvDwhSWDaHNr7q maxclients 32
[0005.24] Log: Retrieved key pair, saving it for this server.
[0005.24] Log: Bringing up level for play took: 0.040867
[0005.24] Log: ########### Finished loading level: 0.171032 seconds
[0005.24] Log: Initializing Game Engine Completed
[0005.29] Log: Flushing async loaders.
[0006.18] Log: Flushed async loaders.
[0006.18] Log: Flushing async loaders.
[0006.50] Log: Flushed async loaders.
[0006.50] Log: Flushing async loaders.
[0006.76] Log: Flushed async loaders.
[0006.76] Log: Flushing async loaders.
[0007.52] Log: Flushed async loaders.
[0007.52] Log: Flushing async loaders.
[0007.61] Log: Flushed async loaders.
[0007.61] Log: Flushing async loaders.
[0007.63] Log: Flushed async loaders.
[0007.63] Log: Flushing async loaders.
[0008.05] Log: Flushed async loaders.
[0008.06] Log: PunkBuster Server: pb_sv_SsNext = 668296 (0 to 999999)
[0008.06] Log: PunkBuster Server: pb_sv_LogNext = 36 (1 to 999999)
[0008.06] Log: PunkBuster Server: PB Log File D:\Steam Games\steamapps\common\America's Army\AAPG\Binaries\win32\pb\svlogs\00000036.log Opened for PG (w)
[0008.06] Log: PunkBuster Server: 0 Power Players loaded from D:\Steam Games\steamapps\common\America's Army\AAPG\Binaries\win32\pb\pbpower.dat
[0008.06] Log: PunkBuster Server: 0 PB Rcon Filters loaded from D:\Steam Games\steamapps\common\America's Army\AAPG\Binaries\win32\pb\pbrcon.dat
[0008.06] Log: PunkBuster Server: 0 Map lines loaded from D:\Steam Games\steamapps\common\America's Army\AAPG\Binaries\win32\pb\pbsvmaps.cfg
[0008.06] Log: PunkBuster Server: Attempting to resolve master2.evenbalance.com
[0008.15] Log: PunkBuster Server: Resolved to [50.62.76.68]
[0008.15] Log: PunkBuster Server: PunkBuster Server for PG (v1.869 | A1376 C2.341) Enabled
[0008.30] Log: No Cached Brush Physics Data Found Or Out Of Date (Model_7) (Owner: BlockingVolume_12) - Cooking Now.
[0008.30] DevPhysics: Error (1) in file ..\..\Cooking\src\ConvexMeshBuilder.cpp, line 77: Supplied NxConvexMeshDesc::checkValid() returned 1.
[0008.30] DevPhysics: Error (4) in file ..\..\src\ExtensionQuickLoad.cpp, line 821: Failed to perform standard cooking of convex mesh.
[0008.34] Log: PunkBuster Server: Game Version [158016]
[0008.83] Log: FKAggregateGeom::InstanceNovodexGeom: (Actor: FTX_Downtown_Lighting.TheWorld:PersistentLevel.StaticMeshActor_124 Component: StaticMeshComponent_40 StaticMesh: MasterSkyWorlds.SkyDome.SM_SkyDomeLatLong) No geometries in FKAggregateGeom.
[0008.83] Log: URB_BodyInstance::InitBody : Could not create new Shape: Actor: FTX_Downtown_Lighting.TheWorld:PersistentLevel.StaticMeshActor_124 Component: StaticMeshComponent_40 StaticMesh: MasterSkyWorlds.SkyDome.SM_SkyDomeLatLong
[0022.73] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server. Trying again in 15.0000 seconds.
[0171.17] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server. Trying again in 15.0000 seconds.

Comments

  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    edited August 20
    "[0005.24] Log: Initializing Game Engine Completed"

    This tells me you DID start a server. There does seem to be a problem though.

    At the bottom of "Host A Server" is a command line window. Could you remove any personal info and post that command line here?

    EDIT: wait a sec...what kind of server are you TRYING to start? LAN or Global?


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    Ehmm Global that is! thanks for the reply!

    "D:\Steam Games\steamapps\common\America's Army\AAPG\Binaries\win32\AAGame.exe" server BDX_Breach_EX /GLOBAL /AuthServerUserName="XXXX" /AuthServerPassword="XXXXX"/AuthServerIP=82.176.186.192 /STEAMSERVERIP=192.168.1.24 MULTIHOME=192.168.1.24 /NOPAUSE /NOHOMEDIR /CONFIGSUBDIR=AAHostAServerConfig0 /SAP=7780 /SGSP=7778 /SQP=27015 /INST=1
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    Judging by the verbosity of the log, this must be the Open Beta build. Have you registered this global server?

    Once you get into Global servers I'm not too experienced....I'd better let someone else take over on this....

    :)


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    Its allright! thanks for your efforts anyway!!
    I did have registered the global server, haven't got any mail to show it has been approved though.
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    As far as I know you need that confirmation before it will work. Good luck!


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    Soo server is fixed! seems to be the authentication indeed!
    Still 1 problem remains..

    Failed to register game with online service. Game won't be advertised
  • AnsuexAnsuex Posts: 10Player
    Basicly my server wont be listed in AA PG servers list.
    How do i fix this?
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    Make sure you actually CAN'T see it first. I wouldn't trust what that log entry actually means (ie I'm not sure.... :p)


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    I've checked a couple of times yes! also let my friend check.
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    Okay. Hmm. Where is it hosted? At home or commercial game server?

    Have you checked ports needed?


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    Its hosted at home PC yes, also i did make sure i have all ports required open.
    Could make a screenshot?
  • AnsuexAnsuex Posts: 10Player
    Ports.png
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    How long since this server was registered? I have heard it takes a bit for the server to be authorized.

    Do you actually have a static, public IP from your ISP or are you behind the ISP firewall? I had that problem and couldn't run a server...

    :(


    It's okay to START small, just don't THINK small....!
  • AnsuexAnsuex Posts: 10Player
    I dont know any better then having a static IP.. it never changed on me so that would mean its static right?
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    Have you tried running other types of servers such as Teamspeak to see if THEY work?

    I'm just brainstorming. I kind of don't know much about this stuff, sorry.


    It's okay to START small, just don't THINK small....!
  • [CLS]_SgtMac[CLS]_SgtMac Posts: 37Player, Moderator, Marine Corp Veteran, Beta Tester
    You should send an email to aacm@americasarmy.com and have them check it for you.
    Keebler750
  • AnsuexAnsuex Posts: 10Player
    i did email.. and i think its because of my ports.
    Have tested them and still seem to be blocked, however i did forward them in my router.
    Might have to contact my ISP? or any other suggestions? :)
  • Keebler750Keebler750 Posts: 527Player, Beta Tester
    Do you have more than one router...ie a cable modem that acts as a router piping signal into your regular router, or something?


    It's okay to START small, just don't THINK small....!
Sign In or Register to comment.